Resolvendo o problema do VMware Player no Ubuntu 15.04 Vivid Vervet.

Como coloquei pra funcionar o VMWare Player após migrar do Ubuntu 14.04 LTS para o 15.04 Beta

Sendo este minha contribuição a título de artigo sobre GNU/Linux, gostaria de fazê-lo de forma simples e clara. Meu problema começou quando efetuei a atualização do Ubuntu 14.04 LTS para a versão 15.04 Beta (Vivid Vervet), ouvi falar muito bem da atualização e fiquei entusiasmado com a possibilidade de contribuir para o projeto.

Após a atualização(que demorou um pouco devido à minha conexão), passei a efetuar as verificações de praxe, se a placas de rede e vídeo estavam operacionais, principais programas funcionando e aproveitando para testar a performance do sistema em si. Ocorre que quando coloquei pra rodar o VMware Player o mesmo não inicializava, apresentava uma mensagem em alerta:

“Before you can run VMware, several modules must be compiled and loaded into running kernel.” Com as opções “Cancel” ou “Install”.

Como todo entusiasta escolhi a opção “Install” (Eu e todo mundo que se deparou com isso pelo que eu pesquisei na net), após uma série de processamento demonstrado numa caixa de diálogo terminava sempre em “Unable to start services. See log file /tmp/vmware-root/vmware-modconfig-****.log for details.” (foram vários desses logs). Pergunta daqui, pesquisa dali, testei diversas soluções postadas aqui mas com outras versões, porém sem sucesso, até que localizei na web (no site: https://wiki.archlinux.org) o problema e a solução descrita abaixo, depois de resolvida, parece muito simples.

Ao que parece já é um problema conhecido do pessoal do site (diversas ligações externas em hiperlinks), o kernel 3.19 do Ubuntu 15.04 causa uma falha de criação da conexão virtual para que o Vmware Player possa funcionar com perfeição, desse modo criou-se um patch para essa correção (você pode acessar e ver aqui: http://pastie.org/9934018) que deve ser aplicado conforme passo a descrever:

1 – Baixe o patch na pasta /tmp digitando no terminal:

$ curl http://pastie.org/pastes/9934018/download -o /tmp/vmnet-3.19.patch

2 – Acesse a biblioteca do vm e extraia o arquivo vmnet conforme a seguir:

$ cd /usr/lib/vmware/modules/source

# tar -xf vmnet.tar

3 – Aplique a correção:

# patch -p0 -i /tmp/vmnet-3.19.patch

4 – Recrie o arquivo:

# tar -cf vmnet.tar vmnet-only

5 – Remova os arquivos de sobra:

# rm -r *-only

6 – Recompile os módulos:

# vmware-modconfig –console –install-all

Pronto. O VMware Player voltou a funcionar e startou a apliance que eu tinha anteriormente, espero que possa ter sido de grande valia a todos. See you later 😉

Fernando “Eagle” de Sousa

VM_Funcionando

%d blogueiros gostam disto: